What’s Vulnerable › Vulnerabilities
CVE-2019-19535
- Severity: medium (CVSS 4.6 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-12-03 · updated 2026-06-17
- Weakness: CWE-908
Description
In the Linux kernel before 5.2.9, there is an info-leak bug that can be caused by a malicious USB device in the drivers/net/can/usb/peak_usb/pcan_usb_fd.c driver, aka CID-30a8beeb3042.
Affected products
- Debian Linux: 8.0
- Linux kernel: before 5.2.9 — fixed in 5.2.9
- openSUSE Leap: 15.1
- Oracle Corporation SD-WAN Edge: 8.2
How to fix
Upgrade to a fixed version: Linux kernel 5.2.9. Check the vendor advisory for mitigations.
References
- http://lists.opensuse.org/opensuse-security-announce/2020-03/msg00021.html
- http://www.openwall.com/lists/oss-security/2019/12/03/4
- https://cdn.kernel.org/pub/linux/kernel/v5.x/ChangeLog-5.2.9
- https://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git/commit/?id=30a8beeb3042f49d0537b7050fd21b490166a3d9
- https://lists.debian.org/debian-lts-announce/2020/03/msg00001.html
- https://www.oracle.com/security-alerts/cpuApr2021.html
- http://lists.opensuse.org/opensuse-security-announce/2020-03/msg00021.html
- http://www.openwall.com/lists/oss-security/2019/12/03/4
- https://cdn.kernel.org/pub/linux/kernel/v5.x/ChangeLog-5.2.9
- https://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git/commit/?id=30a8beeb3042f49d0537b7050fd21b490166a3d9
- https://lists.debian.org/debian-lts-announce/2020/03/msg00001.html
- https://www.oracle.com/security-alerts/cpuApr2021.html
Get alerted when CVE-2019-19535 or the next vulnerability affects your stack