What’s Vulnerable › Vulnerabilities
CVE-2019-19543
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-12-03 · updated 2026-06-17
- Weakness: CWE-416
Description
In the Linux kernel before 5.1.6, there is a use-after-free in serial_ir_init_module() in drivers/media/rc/serial_ir.c.
Affected products
- Linux kernel: before 5.1.6 — fixed in 5.1.6
How to fix
Upgrade to a fixed version: Linux kernel 5.1.6. Check the vendor advisory for mitigations.
References
- http://lists.opensuse.org/opensuse-security-announce/2019-12/msg00029.html
- https://cdn.kernel.org/pub/linux/kernel/v5.x/ChangeLog-5.1.6
- https://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git/commit/?id=56cd26b618855c9af48c8301aa6754ced8dd0beb
- https://security.netapp.com/advisory/ntap-20200924-0005/
- http://lists.opensuse.org/opensuse-security-announce/2019-12/msg00029.html
- https://cdn.kernel.org/pub/linux/kernel/v5.x/ChangeLog-5.1.6
- https://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git/commit/?id=56cd26b618855c9af48c8301aa6754ced8dd0beb
- https://security.netapp.com/advisory/ntap-20200924-0005/
Get alerted when CVE-2019-19543 or the next vulnerability affects your stack