What’s Vulnerable › Vulnerabilities
CVE-2019-1958: Cisco HyperFlex Software Cross-Site Request Forgery Vulnerability
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-08-08 · updated 2026-06-17
- Weakness: CWE-352
Description
A vulnerability in the web-based management interface of Cisco HyperFlex Software could allow an unauthenticated, remote attacker to conduct a cross-site request forgery (CSRF) attack on an affected system. The vulnerability is due to insufficient CSRF protections for the web UI on an affected device. An attacker could exploit this vulnerability by persuading a user of the interface to follow a malicious link. A successful exploit could allow the attacker to perform arbitrary actions with the privilege level of the affected user.
Affected products
- Cisco HyperFlex HX-Series: before 4.0\(2a\) — fixed in 4.0\(2a\)
How to fix
Upgrade to a fixed version: Cisco HyperFlex HX-Series 4.0\(2a\). Check the vendor advisory for mitigations.
References
- https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-20190807-hypflex-csrf
- https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-20190807-hypflex-csrf
Get alerted when CVE-2019-1958 or the next vulnerability affects your stack