What’s Vulnerable › Vulnerabilities
CVE-2019-19588
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2019-12-05 · updated 2026-06-17
- Weakness: CWE-835
Description
The validators package 0.12.2 through 0.12.5 for Python enters an infinite loop when validators.domain is called with a crafted domain string. This is fixed in 0.12.6.
Affected products
- Validators Project Validators: from 0.12.2 through 0.12.5
References
Get alerted when CVE-2019-19588 or the next vulnerability affects your stack