What’s Vulnerable › Vulnerabilities

CVE-2019-19604

Description

Arbitrary command execution is possible in Git before 2.20.2, 2.21.x before 2.21.1, 2.22.x before 2.22.2, 2.23.x before 2.23.1, and 2.24.x before 2.24.1 because a "git submodule update" operation can run commands found in the .gitmodules file of a malicious repository.

Affected products

How to fix

Upgrade to a fixed version: git 2.20.0, 2.21.1, 2.22.2, 2.23.1. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2019-19604 or the next vulnerability affects your stack