What’s Vulnerable › Vulnerabilities
CVE-2019-19606
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2020-03-30 · updated 2026-06-17
- Weakness: CWE-78
Description
X-Plane before 11.41 has multiple improper path validations that could allow reading and writing files from/to arbitrary paths (or a leak of OS credentials to a remote system) via crafted network packets. This could be used to execute arbitrary commands on the system.
Affected products
- X-Plane: before 11.41 — fixed in 11.41
How to fix
Upgrade to a fixed version: X-Plane 11.41. Check the vendor advisory for mitigations.
References
- https://blog.0xlabs.com/2020/03/x-plane-1141-remote-command-execution.html
- https://blog.0xlabs.com/2020/03/x-plane-1141-remote-command-execution.html
Get alerted when CVE-2019-19606 or the next vulnerability affects your stack