What’s Vulnerable › Vulnerabilities
CVE-2019-19617
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-12-06 · updated 2026-06-17
Description
phpMyAdmin before 4.9.2 does not escape certain Git information, related to libraries/classes/Display/GitRevision.php and libraries/classes/Footer.php.
Affected products
- Debian Linux: 8.0, 9.0
- phpMyAdmin: before 4.9.2 — fixed in 4.9.2
How to fix
Upgrade to a fixed version: phpMyAdmin 4.9.2. Check the vendor advisory for mitigations.
References
- https://github.com/phpmyadmin/phpmyadmin/commit/1119de642b136d20e810bb20f545069a01dd7cc9
- https://github.com/phpmyadmin/phpmyadmin/compare/RELEASE_4_9_1...RELEASE_4_9_2
- https://lists.debian.org/debian-lts-announce/2019/12/msg00006.html
- https://lists.debian.org/debian-lts-announce/2020/10/msg00024.html
- https://www.phpmyadmin.net/news/2019/11/22/phpmyadmin-492-released/
- https://github.com/phpmyadmin/phpmyadmin/commit/1119de642b136d20e810bb20f545069a01dd7cc9
- https://github.com/phpmyadmin/phpmyadmin/compare/RELEASE_4_9_1...RELEASE_4_9_2
- https://lists.debian.org/debian-lts-announce/2019/12/msg00006.html
- https://lists.debian.org/debian-lts-announce/2020/10/msg00024.html
- https://www.phpmyadmin.net/news/2019/11/22/phpmyadmin-492-released/
Get alerted when CVE-2019-19617 or the next vulnerability affects your stack