What’s Vulnerable › Vulnerabilities
CVE-2019-1964: Cisco NX-OS Software IPv6 Denial of Service Vulnerability
- Severity: high (CVSS 7.5 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-08-28 · updated 2026-06-17
- Weakness: CWE-20
Description
A vulnerability in the IPv6 traffic processing of Cisco NX-OS Software could allow an unauthenticated, remote attacker to cause an unexpected restart of the netstack process on an affected device. The vulnerability is due to improper validation of IPv6 traffic sent through an affected device. An attacker could exploit this vulnerability by sending a malformed IPv6 packet through an affected device. A successful exploit could allow the attacker to cause a denial of service (DoS) condition while the netstack process restarts. A sustained attack could lead to a reboot of the device.
Affected products
- Cisco NX-OS: from 8.1 before 8.2\(3\); from 8.3 before 8.4 — fixed in 8.2\(3\), 8.4
How to fix
Upgrade to a fixed version: Cisco NX-OS 8.2\(3\), 8.4. Check the vendor advisory for mitigations.
References
- https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-20190828-nxos-ipv6-dos
- https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-20190828-nxos-ipv6-dos
Get alerted when CVE-2019-1964 or the next vulnerability affects your stack