What’s Vulnerable › Vulnerabilities
CVE-2019-19728
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-01-13 · updated 2026-06-17
- Weakness: CWE-269
Description
SchedMD Slurm before 18.08.9 and 19.x before 19.05.5 executes srun --uid with incorrect privileges.
Affected products
- Debian Linux: 10.0
- openSUSE Leap: 15.1
- SchedMD Slurm: before 18.08.9; from 19.05.0 before 19.05.5 — fixed in 18.08.9, 19.05.5
How to fix
Upgrade to a fixed version: SchedMD Slurm 18.08.9, 19.05.5. Check the vendor advisory for mitigations.
References
- http://lists.opensuse.org/opensuse-security-announce/2020-01/msg00038.html
- https://bugzilla.suse.com/show_bug.cgi?id=1159692
- https://lists.schedmd.com/pipermail/slurm-announce/
- https://www.debian.org/security/2021/dsa-4841
- https://www.schedmd.com/news.php
- http://lists.opensuse.org/opensuse-security-announce/2020-01/msg00038.html
- https://bugzilla.suse.com/show_bug.cgi?id=1159692
- https://lists.schedmd.com/pipermail/slurm-announce/
- https://www.debian.org/security/2021/dsa-4841
- https://www.schedmd.com/news.php
Get alerted when CVE-2019-19728 or the next vulnerability affects your stack