What’s Vulnerable › Vulnerabilities
CVE-2019-1973: Cisco Enterprise NFV Infrastructure Software Cross-site Scripting Vulnerability
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-08-08 · updated 2026-08-24
- Weakness: CWE-79
Description
A vulnerability in the web portal framework of Cisco Enterprise NFV Infrastructure Software (NFVIS) could allow an authenticated, remote attacker to conduct a cross-site scripting (XSS) attack against a user of the web-based interface. The vulnerability is due to improper input validation of log file content stored on the affected device. An attacker could exploit this vulnerability by modifying a log file with malicious code and getting a user to view the modified log file. A successful exploit could allow the attacker to execute arbitrary script code in the context of the affected interface or to access sensitive, browser-based information.
Affected products
- Cisco Enterprise NFV Infrastructure Software: before 3.11.1 — fixed in 3.11.1
How to fix
Upgrade to a fixed version: Cisco Enterprise NFV Infrastructure Software 3.11.1. Check the vendor advisory for mitigations.
References
- https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-20190807-nfv-xss
- https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-20190807-nfv-xss
Get alerted when CVE-2019-1973 or the next vulnerability affects your stack