What’s Vulnerable › Vulnerabilities
CVE-2019-19757
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-02-14 · updated 2026-06-17
- Weakness: CWE-79
Description
An internal product security audit of Lenovo XClarity Administrator (LXCA) discovered a Document Object Model (DOM) based cross-site scripting vulnerability in versions prior to 2.6.6 that could allow JavaScript code to be executed in the user's web browser if a specially crafted link is visited. The JavaScript code is executed on the user's system, not executed on LXCA itself.
Affected products
- Lenovo XClarity Administrator: before 2.6.6 — fixed in 2.6.6
How to fix
Upgrade to a fixed version: Lenovo XClarity Administrator 2.6.6. Check the vendor advisory for mitigations.
References
- https://support.lenovo.com/us/en/product_security/LEN-29477
- https://support.lenovo.com/us/en/product_security/LEN-29477
Get alerted when CVE-2019-19757 or the next vulnerability affects your stack