What’s Vulnerable › Vulnerabilities
CVE-2019-19783
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-12-16 · updated 2026-06-17
- Weakness: CWE-269
Description
An issue was discovered in Cyrus IMAP before 2.5.15, 3.0.x before 3.0.13, and 3.1.x through 3.1.8. If sieve script uploading is allowed (3.x) or certain non-default sieve options are enabled (2.x), a user with a mail account on the service can use a sieve script containing a fileinto directive to create any mailbox with administrator privileges, because of folder mishandling in autosieve_createfolder() in imap/lmtp_sieve.c.
Affected products
- Canonical Ubuntu Linux: 18.04
- cyrusimap Cyrus IMAP: from 2.5.0 before 2.5.15; from 3.0.0 before 3.0.13; from 3.1.0 before 3.1.8 — fixed in 2.5.15, 3.0.13, 3.1.8
- Debian Linux: 9.0, 10.0
- Fedoraproject Fedora: 30, 31
How to fix
Upgrade to a fixed version: cyrusimap Cyrus IMAP 2.5.15, 3.0.13, 3.1.8. Check the vendor advisory for mitigations.
References
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/2DIV4HQ6LG5GPRO4B5Z2NHCZUPBUVVVF/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/6IGOO5UGEBBDPN7B2YXLK7I7L3Y35EBA/
- https://seclists.org/bugtraq/2019/Dec/38
- https://security.gentoo.org/glsa/202006-23
- https://usn.ubuntu.com/4566-1/
- https://www.cyrusimap.org/imap/download/release-notes/2.5/x/2.5.15.html
- https://www.cyrusimap.org/imap/download/release-notes/3.0/x/3.0.13.html
- https://www.debian.org/security/2019/dsa-4590
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/2DIV4HQ6LG5GPRO4B5Z2NHCZUPBUVVVF/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/6IGOO5UGEBBDPN7B2YXLK7I7L3Y35EBA/
- https://seclists.org/bugtraq/2019/Dec/38
- https://security.gentoo.org/glsa/202006-23
Get alerted when CVE-2019-19783 or the next vulnerability affects your stack