What’s Vulnerable › Vulnerabilities
CVE-2019-19791
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-05-29 · updated 2026-06-17
Description
In LemonLDAP::NG (aka lemonldap-ng) before 2.0.7, the default Apache HTTP Server configuration does not properly restrict access to SOAP/REST endpoints (when some LemonLDAP::NG setup options are used). For example, an attacker can insert index.fcgi/index.fcgi into a URL to bypass a Require directive.
Affected products
- lemonldap-ng Lemonldap::Ng: before 2.0.7 — fixed in 2.0.7
How to fix
Upgrade to a fixed version: lemonldap-ng Lemonldap::Ng 2.0.7. Check the vendor advisory for mitigations.
References
- https://gitlab.ow2.org/lemonldap-ng/lemonldap-ng/issues/1943
- https://projects.ow2.org/view/lemonldap-ng/lemonldap-ng-2-0-7-is-out
- https://gitlab.ow2.org/lemonldap-ng/lemonldap-ng/issues/1943
- https://projects.ow2.org/view/lemonldap-ng/lemonldap-ng-2-0-7-is-out
Get alerted when CVE-2019-19791 or the next vulnerability affects your stack