What’s Vulnerable › Vulnerabilities
CVE-2019-19821
- Severity: high (CVSS 8.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-03-16 · updated 2026-06-17
- Weakness: CWE-79
Description
A post-authentication privilege escalation in the web application of Combodo iTop allows regular authenticated users to access information and modify information with administrative privileges by not following the HTTP Location header in server responses. This is fixed in all iTop packages (community, essential, professional) in versions : 2.5.4, 2.6.3, 2.7.0
Affected products
- Combodo iTop: before 2.7 — fixed in 2.7
How to fix
Upgrade to a fixed version: Combodo iTop 2.7. Check the vendor advisory for mitigations.
References
- https://github.com/Combodo/iTop/security/advisories/GHSA-2gfp-2qvh-9796
- https://www.combodo.com/itop-193
- https://www.pentagrid.ch/de/blog/security_issues_in_teampasswordmanager_and_combodo_itop/
- https://github.com/Combodo/iTop/security/advisories/GHSA-2gfp-2qvh-9796
- https://www.combodo.com/itop-193
- https://www.pentagrid.ch/de/blog/security_issues_in_teampasswordmanager_and_combodo_itop/
Get alerted when CVE-2019-19821 or the next vulnerability affects your stack