What’s Vulnerable › Vulnerabilities
CVE-2019-19830
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-12-17 · updated 2026-06-17
Description
_core_/plugins/medias in SPIP 3.2.x before 3.2.7 allows remote authenticated authors to inject content into the database.
Affected products
- Canonical Ubuntu Linux: 18.04
- Debian Linux: 9.0, 10.0
- SPIP: from 3.2.0 before 3.2.7 — fixed in 3.2.7
How to fix
Upgrade to a fixed version: SPIP 3.2.7. Check the vendor advisory for mitigations.
References
- https://blog.spip.net/Mise-a-jour-CRITIQUE-de-securite-sortie-de-SPIP-3-2-7-SPIP-3-1-12.html
- https://git.spip.net/SPIP/spip/commit/8eb11ba132b92696eb34d606d71aa8edf40e0f69
- https://usn.ubuntu.com/4536-1/
- https://www.debian.org/security/2019/dsa-4583
- https://zone.spip.net/trac/spip-zone/changeset/118898/spip-zone/_core_/plugins/medias
- https://blog.spip.net/Mise-a-jour-CRITIQUE-de-securite-sortie-de-SPIP-3-2-7-SPIP-3-1-12.html
- https://git.spip.net/SPIP/spip/commit/8eb11ba132b92696eb34d606d71aa8edf40e0f69
- https://usn.ubuntu.com/4536-1/
- https://www.debian.org/security/2019/dsa-4583
- https://zone.spip.net/trac/spip-zone/changeset/118898/spip-zone/_core_/plugins/medias
Get alerted when CVE-2019-19830 or the next vulnerability affects your stack