What’s Vulnerable › Vulnerabilities

CVE-2019-19849

Description

An issue was discovered in TYPO3 before 8.7.30, 9.x before 9.5.12, and 10.x before 10.2.2. It has been discovered that the classes QueryGenerator and QueryView are vulnerable to insecure deserialization. One exploitable scenario requires having the system extension ext:lowlevel (Backend Module: DB Check) installed, with a valid backend user who has administrator privileges. The other exploitable scenario requires having the system extension ext:sys_action installed, with a valid backend user who has limited privileges.

Affected products

How to fix

Upgrade to a fixed version: typo3 10.2.2, 8.7.30, 9.5.12. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2019-19849 or the next vulnerability affects your stack