What’s Vulnerable › Vulnerabilities
CVE-2019-19850
- Severity: high (CVSS 7.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-12-17 · updated 2026-06-17
- Weakness: CWE-89
Description
An issue was discovered in TYPO3 before 8.7.30, 9.x before 9.5.12, and 10.x before 10.2.2. Because escaping of user-submitted content is mishandled, the class QueryGenerator is vulnerable to SQL injection. Exploitation requires having the system extension ext:lowlevel installed, and a valid backend user who has administrator privileges.
Affected products
- typo3: from 8.0.0 before 8.7.30; from 9.0.0 before 9.5.12; from 10.0.0 before 10.2.2 — fixed in 10.2.2, 8.7.30, 9.5.12
How to fix
Upgrade to a fixed version: typo3 10.2.2, 8.7.30, 9.5.12. Check the vendor advisory for mitigations.
References
- https://review.typo3.org/q/%2522Resolves:+%252389452%2522+topic:security
- https://typo3.org/security/advisory/typo3-core-sa-2019-025/
- https://review.typo3.org/q/%2522Resolves:+%252389452%2522+topic:security
- https://typo3.org/security/advisory/typo3-core-sa-2019-025/
Get alerted when CVE-2019-19850 or the next vulnerability affects your stack