What’s Vulnerable › Vulnerabilities
CVE-2019-19885
- Severity: critical (CVSS 9.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-10-16 · updated 2026-06-17
- Weakness: CWE-862
Description
In Bender COMTRAXX, user authorization is validated for most, but not all, routes in the system. A user with knowledge about the routes can read and write configuration data without prior authorization. This affects COM465IP, COM465DP, COM465ID, CP700, CP907, and CP915 devices before 4.2.0.
Affected products
- Bender Com465Dp Firmware: before 4.2.0 — fixed in 4.2.0
- Bender Com465Id Firmware: before 4.2.0 — fixed in 4.2.0
- Bender Com465Ip Firmware: before 4.2.0 — fixed in 4.2.0
- Bender Cp700 Firmware: before 4.2.0 — fixed in 4.2.0
- Bender Cp907 Firmware: before 4.2.0 — fixed in 4.2.0
- Bender Cp915 Firmware: before 4.2.0 — fixed in 4.2.0
How to fix
Upgrade to a fixed version: Bender Com465Dp Firmware 4.2.0; Bender Com465Id Firmware 4.2.0; Bender Com465Ip Firmware 4.2.0; Bender Cp700 Firmware 4.2.0; Bender Cp907 Firmware 4.2.0; Bender Cp915 Firmware 4.2.0. Check the vendor advisory for mitigations.
References
- https://cert.vde.com/en-us/advisories/vde-2020-043
- https://cert.vde.com/en-us/advisories/vde-2020-043
Get alerted when CVE-2019-19885 or the next vulnerability affects your stack