What’s Vulnerable › Vulnerabilities

CVE-2019-19902

Description

An issue was discovered in Backdrop CMS 1.13.x before 1.13.5 and 1.14.x before 1.14.2. It allows the upload of entire-site configuration archives through the user interface or command line. It does not sufficiently check uploaded archives for invalid data, allowing non-configuration scripts to potentially be uploaded to the server. This issue is mitigated by the fact that the attacker would be required to have the "Synchronize, import, and export configuration" permission, a permission that only trusted administrators should be given. Other measures in the product prevent the execution of PHP scripts, so another server-side scripting language must be accessible on the server to execute code.

Affected products

How to fix

Upgrade to a fixed version: BackdropCMS Backdrop 1.13.5, 1.14.2. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2019-19902 or the next vulnerability affects your stack