What’s Vulnerable › Vulnerabilities
CVE-2019-19905
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-12-19 · updated 2026-06-17
- Weakness: CWE-120
Description
NetHack 3.6.x before 3.6.4 is prone to a buffer overflow vulnerability when reading very long lines from configuration files. This affects systems that have NetHack installed suid/sgid, and shared systems that allow users to upload their own configuration files.
Affected products
- NetHack: from 3.6.0 before 3.6.4 — fixed in 3.6.4
How to fix
Upgrade to a fixed version: NetHack 3.6.4. Check the vendor advisory for mitigations.
References
- https://bugs.debian.org/947005
- https://github.com/NetHack/NetHack/commit/f001de79542b8c38b1f8e6d7eaefbbd28ab94b47
- https://github.com/NetHack/NetHack/commit/f4a840a48f4bcf11757b3d859e9d53cc9d5ef226
- https://github.com/NetHack/NetHack/security/advisories/GHSA-3cm7-rgh5-9pq5
- https://nethack.org/security/
- https://bugs.debian.org/947005
- https://github.com/NetHack/NetHack/commit/f001de79542b8c38b1f8e6d7eaefbbd28ab94b47
- https://github.com/NetHack/NetHack/commit/f4a840a48f4bcf11757b3d859e9d53cc9d5ef226
- https://github.com/NetHack/NetHack/security/advisories/GHSA-3cm7-rgh5-9pq5
- https://nethack.org/security/
Get alerted when CVE-2019-19905 or the next vulnerability affects your stack