What’s Vulnerable › Vulnerabilities
CVE-2019-19911
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-01-05 · updated 2026-06-17
- Weakness: CWE-190
Description
There is a DoS vulnerability in Pillow before 6.2.2 caused by FpxImagePlugin.py calling the range function on an unvalidated 32-bit integer if the number of bands is large. On Windows running 32-bit Python, this results in an OverflowError or MemoryError due to the 2 GB limit. However, on Linux running 64-bit Python this results in the process being terminated by the OOM killer.
Affected products
- Canonical Ubuntu Linux: 14.04, 16.04, 18.04, 19.10
- Debian Linux: 9.0, 10.0
- Fedoraproject Fedora: 30
- python-pillow Pillow: before 6.2.2 — fixed in 6.2.2
How to fix
Upgrade to a fixed version: python-pillow Pillow 6.2.2. Check the vendor advisory for mitigations.
References
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/3DUMIBUYGJRAVJCTFUWBRLVQKOUTVX5P/
- https://pillow.readthedocs.io/en/stable/releasenotes/6.2.2.html
- https://usn.ubuntu.com/4272-1/
- https://www.debian.org/security/2020/dsa-4631
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/3DUMIBUYGJRAVJCTFUWBRLVQKOUTVX5P/
- https://pillow.readthedocs.io/en/stable/releasenotes/6.2.2.html
- https://usn.ubuntu.com/4272-1/
- https://www.debian.org/security/2020/dsa-4631
Get alerted when CVE-2019-19911 or the next vulnerability affects your stack