What’s Vulnerable › Vulnerabilities
CVE-2019-19915
- Severity: critical (CVSS 9.0 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2019-12-19 · updated 2026-06-17
- Weakness: CWE-352
Description
The "301 Redirects - Easy Redirect Manager" plugin before 2.45 for WordPress allows users (with subscriber or greater access) to modify, delete, or inject redirect rules, and exploit XSS, with the /admin-ajax.php?action=eps_redirect_save and /admin-ajax.php?action=eps_redirect_delete actions. This could result in a loss of site availability, malicious redirects, and user infections. This could also be exploited via CSRF.
Affected products
- 301 Redirects - Easy Redirect Manager: before 2.45 — fixed in 2.45
How to fix
Upgrade to a fixed version: 301 Redirects - Easy Redirect Manager 2.45. Check the vendor advisory for mitigations.
References
- https://wpvulndb.com/vulnerabilities/9979
- https://www.wordfence.com/blog/2019/12/critical-vulnerability-patched-in-301-redirects-easy-redirect-manager/
- https://wpvulndb.com/vulnerabilities/9979
- https://www.wordfence.com/blog/2019/12/critical-vulnerability-patched-in-301-redirects-easy-redirect-manager/
Get alerted when CVE-2019-19915 or the next vulnerability affects your stack