What’s Vulnerable › Vulnerabilities
CVE-2019-19935
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.8% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2020-07-07 · updated 2026-06-17
- Weakness: CWE-79
Description
Froala Editor before 3.2.3 allows XSS.
Affected products
- Froala Editor: before 3.2.3 — fixed in 3.2.3
How to fix
Upgrade to a fixed version: Froala Editor 3.2.3. Check the vendor advisory for mitigations.
References
- http://packetstormsecurity.com/files/158300/Froala-WYSIWYG-HTML-Editor-3.1.1-Cross-Site-Scripting.html
- https://blog.compass-security.com/2020/07/yet-another-froala-0-day-xss/
- https://compass-security.com/fileadmin/Datein/Research/Advisories/CSNC-2020-004_DOM_XSS_in_Froala_WYSIWYG_HTML_Editor.txt
- https://github.com/froala/wysiwyg-editor/compare/v3.0.5...v3.0.6
- https://snyk.io/vuln/npm:froala-editor
- http://packetstormsecurity.com/files/158300/Froala-WYSIWYG-HTML-Editor-3.1.1-Cross-Site-Scripting.html
- https://blog.compass-security.com/2020/07/yet-another-froala-0-day-xss/
- https://compass-security.com/fileadmin/Datein/Research/Advisories/CSNC-2020-004_DOM_XSS_in_Froala_WYSIWYG_HTML_Editor.txt
- https://github.com/froala/wysiwyg-editor/compare/v3.0.5...v3.0.6
- https://snyk.io/vuln/npm:froala-editor
Get alerted when CVE-2019-19935 or the next vulnerability affects your stack