What’s Vulnerable › Vulnerabilities
CVE-2019-19949
- Severity: critical (CVSS 9.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.9% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2019-12-24 · updated 2026-06-17
- Weakness: CWE-125
Description
In ImageMagick 7.0.8-43 Q16, there is a heap-based buffer over-read in the function WritePNGImage of coders/png.c, related to Magick_png_write_raw_profile and LocaleNCompare.
Affected products
- Canonical Ubuntu Linux: 20.04
- Debian Linux: 8.0, 9.0, 10.0
- ImageMagick: from 6.9.9-33 before 6.9.10-43; from 7.0.7-23 before 7.0.8-43 — fixed in 6.9.10-43, 7.0.8-43
- openSUSE Leap: 15.1
How to fix
Upgrade to a fixed version: ImageMagick 6.9.10-43, 7.0.8-43. Check the vendor advisory for mitigations.
References
- http://lists.opensuse.org/opensuse-security-announce/2020-02/msg00006.html
- https://github.com/ImageMagick/ImageMagick/issues/1561
- https://lists.debian.org/debian-lts-announce/2019/12/msg00033.html
- https://lists.debian.org/debian-lts-announce/2020/08/msg00030.html
- https://usn.ubuntu.com/4549-1/
- https://www.debian.org/security/2020/dsa-4712
- http://lists.opensuse.org/opensuse-security-announce/2020-02/msg00006.html
- https://github.com/ImageMagick/ImageMagick/issues/1561
- https://lists.debian.org/debian-lts-announce/2019/12/msg00033.html
- https://lists.debian.org/debian-lts-announce/2020/08/msg00030.html
- https://usn.ubuntu.com/4549-1/
- https://www.debian.org/security/2020/dsa-4712
Get alerted when CVE-2019-19949 or the next vulnerability affects your stack