What’s Vulnerable › Vulnerabilities
CVE-2019-19960
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-12-25 · updated 2026-06-17
Description
In wolfSSL before 4.3.0, wc_ecc_mulmod_ex does not properly resist side-channel attacks.
Affected products
- wolfSSL: before 4.3.0 — fixed in 4.3.0
How to fix
Upgrade to a fixed version: wolfSSL 4.3.0. Check the vendor advisory for mitigations.
References
- https://github.com/wolfSSL/wolfssl/commit/5ee9f9c7a23f8ed093fe1e42bc540727e96cebb8
- https://github.com/wolfSSL/wolfssl/releases/tag/v4.3.0-stable
- https://github.com/wolfSSL/wolfssl/commit/5ee9f9c7a23f8ed093fe1e42bc540727e96cebb8
- https://github.com/wolfSSL/wolfssl/releases/tag/v4.3.0-stable
Get alerted when CVE-2019-19960 or the next vulnerability affects your stack