What’s Vulnerable › Vulnerabilities
CVE-2019-19962
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-12-25 · updated 2026-06-17
- Weakness: CWE-347
Description
wolfSSL before 4.3.0 mishandles calls to wc_SignatureGenerateHash, leading to fault injection in RSA cryptography.
Affected products
- wolfSSL: before 4.3.0 — fixed in 4.3.0
How to fix
Upgrade to a fixed version: wolfSSL 4.3.0. Check the vendor advisory for mitigations.
References
- https://github.com/wolfSSL/wolfssl/commit/23878512c65834d12811b1107d19a001478eca5d
- https://github.com/wolfSSL/wolfssl/releases/tag/v4.3.0-stable
- https://github.com/wolfSSL/wolfssl/commit/23878512c65834d12811b1107d19a001478eca5d
- https://github.com/wolfSSL/wolfssl/releases/tag/v4.3.0-stable
Get alerted when CVE-2019-19962 or the next vulnerability affects your stack