What’s Vulnerable › Vulnerabilities
CVE-2019-19979
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2019-12-26 · updated 2026-06-17
- Weakness: CWE-79
Description
A flaw in the WordPress plugin, WP Maintenance before 5.0.6, allowed attackers to enable a vulnerable site's maintenance mode and inject malicious code affecting site visitors. There was CSRF with resultant XSS.
Affected products
- Florent Maillefaud WP Maintenance: before 5.0.6 — fixed in 5.0.6
How to fix
Upgrade to a fixed version: Florent Maillefaud WP Maintenance 5.0.6. Check the vendor advisory for mitigations.
References
- https://wpvulndb.com/vulnerabilities/9954
- https://www.wordfence.com/blog/2019/11/high-severity-vulnerability-patched-in-wp-maintenance-plugin/
- https://wpvulndb.com/vulnerabilities/9954
- https://www.wordfence.com/blog/2019/11/high-severity-vulnerability-patched-in-wp-maintenance-plugin/
Get alerted when CVE-2019-19979 or the next vulnerability affects your stack