What’s Vulnerable › Vulnerabilities
CVE-2019-20008
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2019-12-26 · updated 2026-06-17
- Weakness: CWE-79
Description
In Archery before 1.3, inserting an XSS payload into a project name (either by creating a new project or editing an existing one) will result in stored XSS on the vulnerability-scan scheduling page.
Affected products
- archerysec Archery: before 1.3 — fixed in 1.3
How to fix
Upgrade to a fixed version: archerysec Archery 1.3. Check the vendor advisory for mitigations.
References
- https://github.com/archerysec/archerysec/compare/archerysec-v1.2...v1.3
- https://github.com/archerysec/archerysec/issues/338
- https://github.com/archerysec/archerysec/releases/tag/v1.3
- https://github.com/archerysec/archerysec/compare/archerysec-v1.2...v1.3
- https://github.com/archerysec/archerysec/issues/338
- https://github.com/archerysec/archerysec/releases/tag/v1.3
Get alerted when CVE-2019-20008 or the next vulnerability affects your stack