What’s Vulnerable › Vulnerabilities
CVE-2019-20014
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2019-12-27 · updated 2026-06-17
- Weakness: CWE-415
Description
An issue was discovered in GNU LibreDWG before 0.93. There is a double-free in dwg_free in free.c.
Affected products
- GNU LibreDWG: before 0.9.3 — fixed in 0.9.3
- openSUSE Backports Sle: 15.0-sp1
- openSUSE Leap: 15.1
How to fix
Upgrade to a fixed version: GNU LibreDWG 0.9.3. Check the vendor advisory for mitigations.
References
- http://lists.opensuse.org/opensuse-security-announce/2020-01/msg00033.html
- http://lists.opensuse.org/opensuse-security-announce/2020-01/msg00045.html
- https://github.com/LibreDWG/libredwg/compare/0.9.2...0.9.3
- https://github.com/LibreDWG/libredwg/issues/176
- https://github.com/LibreDWG/libredwg/issues/176#issuecomment-568643172
- http://lists.opensuse.org/opensuse-security-announce/2020-01/msg00033.html
- http://lists.opensuse.org/opensuse-security-announce/2020-01/msg00045.html
- https://github.com/LibreDWG/libredwg/compare/0.9.2...0.9.3
- https://github.com/LibreDWG/libredwg/issues/176
- https://github.com/LibreDWG/libredwg/issues/176#issuecomment-568643172
Get alerted when CVE-2019-20014 or the next vulnerability affects your stack