What’s Vulnerable › Vulnerabilities
CVE-2019-20041
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 4.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-12-27 · updated 2026-06-17
- Weakness: CWE-20
Description
wp_kses_bad_protocol in wp-includes/kses.php in WordPress before 5.3.1 mishandles the HTML5 colon named entity, allowing attackers to bypass input sanitization, as demonstrated by the javascript: substring.
Affected products
- Debian Linux: 8.0, 9.0, 10.0
- WordPress: before 5.3.1 — fixed in 5.3.1
How to fix
Upgrade to a fixed version: WordPress 5.3.1. Check the vendor advisory for mitigations.
References
- https://github.com/WordPress/wordpress-develop/commit/b1975463dd995da19bb40d3fa0786498717e3c53
- https://lists.debian.org/debian-lts-announce/2020/01/msg00010.html
- https://seclists.org/bugtraq/2020/Jan/8
- https://wordpress.org/news/2019/12/wordpress-5-3-1-security-and-maintenance-release/
- https://www.debian.org/security/2020/dsa-4599
- https://www.debian.org/security/2020/dsa-4677
- https://github.com/WordPress/wordpress-develop/commit/b1975463dd995da19bb40d3fa0786498717e3c53
- https://lists.debian.org/debian-lts-announce/2020/01/msg00010.html
- https://seclists.org/bugtraq/2020/Jan/8
- https://wordpress.org/news/2019/12/wordpress-5-3-1-security-and-maintenance-release/
- https://www.debian.org/security/2020/dsa-4599
- https://www.debian.org/security/2020/dsa-4677
Get alerted when CVE-2019-20041 or the next vulnerability affects your stack