What’s Vulnerable › Vulnerabilities
CVE-2019-20042
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-12-27 · updated 2026-06-17
- Weakness: CWE-79
Description
In wp-includes/formatting.php in WordPress 3.7 to 5.3.0, the function wp_targeted_link_rel() can be used in a particular way to result in a stored cross-site scripting (XSS) vulnerability. This has been patched in WordPress 5.3.1, along with all the previous WordPress versions from 3.7 to 5.3 via a minor release.
Affected products
- Debian Linux: 9.0, 10.0
- WordPress: from 3.7 before 5.3.1 — fixed in 5.3.1
How to fix
Upgrade to a fixed version: WordPress 5.3.1. Check the vendor advisory for mitigations.
References
- https://blog.ripstech.com/filter/vulnerabilities/
- https://core.trac.wordpress.org/changeset/46894/trunk
- https://github.com/WordPress/wordpress-develop/commit/1f7f3f1f59567e2504f0fbebd51ccf004b3ccb1d
- https://github.com/WordPress/wordpress-develop/security/advisories/GHSA-xvg2-m2f4-83m7
- https://hackerone.com/reports/509930
- https://seclists.org/bugtraq/2020/Jan/8
- https://wordpress.org/news/2019/12/wordpress-5-3-1-security-and-maintenance-release/
- https://wpvulndb.com/vulnerabilities/9975
- https://www.debian.org/security/2020/dsa-4599
- https://www.debian.org/security/2020/dsa-4677
- https://blog.ripstech.com/filter/vulnerabilities/
- https://core.trac.wordpress.org/changeset/46894/trunk
Get alerted when CVE-2019-20042 or the next vulnerability affects your stack