What’s Vulnerable › Vulnerabilities
CVE-2019-20043
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-12-27 · updated 2026-06-17
- Weakness: CWE-269
Description
In in wp-includes/rest-api/endpoints/class-wp-rest-posts-controller.php in WordPress 3.7 to 5.3.0, authenticated users who do not have the rights to publish a post are able to mark posts as sticky or unsticky via the REST API. For example, the contributor role does not have such rights, but this allowed them to bypass that. This has been patched in WordPress 5.3.1, along with all the previous WordPress versions from 3.7 to 5.3 via a minor release.
Affected products
- Debian Linux: 9.0, 10.0
- WordPress: from 3.7 before 5.3.1 — fixed in 5.3.1
How to fix
Upgrade to a fixed version: WordPress 5.3.1. Check the vendor advisory for mitigations.
References
- https://core.trac.wordpress.org/changeset/46893/trunk
- https://github.com/WordPress/wordpress-develop/commit/1d1d5be7aa94608c04516cac4238e8c22b93c1d9
- https://github.com/WordPress/wordpress-develop/security/advisories/GHSA-g7rg-hchx-c2gw
- https://seclists.org/bugtraq/2020/Jan/8
- https://wordpress.org/news/2019/12/wordpress-5-3-1-security-and-maintenance-release/
- https://wpvulndb.com/vulnerabilities/9973
- https://www.debian.org/security/2020/dsa-4599
- https://www.debian.org/security/2020/dsa-4677
- https://core.trac.wordpress.org/changeset/46893/trunk
- https://github.com/WordPress/wordpress-develop/commit/1d1d5be7aa94608c04516cac4238e8c22b93c1d9
- https://github.com/WordPress/wordpress-develop/security/advisories/GHSA-g7rg-hchx-c2gw
- https://seclists.org/bugtraq/2020/Jan/8
Get alerted when CVE-2019-20043 or the next vulnerability affects your stack