What’s Vulnerable › Vulnerabilities
CVE-2019-20079
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-12-30 · updated 2026-06-17
- Weakness: CWE-416
Description
The autocmd feature in window.c in Vim before 8.1.2136 accesses freed memory.
Affected products
- Canonical Ubuntu Linux: 12.04, 14.04, 16.04, 18.04, 19.10
- vim/vim: from 8.1.2121 before 8.1.2136 — fixed in 8.1.2136
How to fix
Upgrade to a fixed version: vim/vim 8.1.2136. Check the vendor advisory for mitigations.
References
- https://github.com/vim/vim/commit/ec66c41d84e574baf8009dbc0bd088d2bc5b2421
- https://github.com/vim/vim/compare/v8.1.2135...v8.1.2136
- https://packetstormsecurity.com/files/154898
- https://usn.ubuntu.com/4309-1/
- https://github.com/vim/vim/commit/ec66c41d84e574baf8009dbc0bd088d2bc5b2421
- https://github.com/vim/vim/compare/v8.1.2135...v8.1.2136
- https://packetstormsecurity.com/files/154898
- https://usn.ubuntu.com/4309-1/
Get alerted when CVE-2019-20079 or the next vulnerability affects your stack