What’s Vulnerable › Vulnerabilities
CVE-2019-20100
- Severity: medium (CVSS 4.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2020-02-12 · updated 2026-06-17
- Weakness: CWE-352
Description
The Atlassian Application Links plugin is vulnerable to cross-site request forgery (CSRF). The following versions are affected: all versions prior to 5.4.21, from version 6.0.0 before version 6.0.12, from version 6.1.0 before version 6.1.2, from version 7.0.0 before version 7.0.2, and from version 7.1.0 before version 7.1.3. The vulnerable plugin is used by Atlassian Jira Server and Data Center before version 8.7.0. An attacker could exploit this by tricking an administrative user into making malicious HTTP requests, allowing the attacker to enumerate hosts and open ports on the internal network where Jira server is present.
Affected products
- Atlassian Jira: from 7.0.0 before 8.4.5 — fixed in 8.4.5
- Atlassian Jira: from 7.0.0 before 8.5.4; from 8.5.5 before 8.6.2 — fixed in 8.5.4, 8.6.2
- Atlassian Jira: from 8.5.5 before 8.6.2 — fixed in 8.6.2
How to fix
Upgrade to a fixed version: Atlassian Jira 8.4.5; Atlassian Jira 8.5.4, 8.6.2; Atlassian Jira 8.6.2. Check the vendor advisory for mitigations.
References
- https://ecosystem.atlassian.net/browse/APL-1390
- https://jira.atlassian.com/browse/JRASERVER-70607
- https://www.tenable.com/security/research/tra-2020-06
- https://ecosystem.atlassian.net/browse/APL-1390
- https://jira.atlassian.com/browse/JRASERVER-70607
- https://www.tenable.com/security/research/tra-2020-06
Get alerted when CVE-2019-20100 or the next vulnerability affects your stack