What’s Vulnerable › Vulnerabilities
CVE-2019-20102
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-04-22 · updated 2026-06-17
- Weakness: CWE-79
Description
The attachment-uploading feature in Atlassian Confluence Server from version 6.14.0 through version 6.14.3, and version 6.15.0 before version 6.15.5 allows remote attackers to achieve stored cross-site- scripting (SXSS) via a malicious attachment with a modified `mimeType` parameter.
Affected products
- Atlassian Confluence Data Center: from 6.14.0 through 6.14.3; from 6.15.0 before 6.15.5 — fixed in 6.15.5
How to fix
Upgrade to a fixed version: Atlassian Confluence Data Center 6.15.5. Check the vendor advisory for mitigations.
References
- https://jira.atlassian.com/browse/CONFSERVER-59358
- https://jira.atlassian.com/browse/CONFSERVER-59358
Get alerted when CVE-2019-20102 or the next vulnerability affects your stack