What’s Vulnerable › Vulnerabilities
CVE-2019-20174
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2020-02-03 · updated 2026-06-17
- Weakness: CWE-79
Description
Auth0 Lock before 11.21.0 allows XSS when additionalSignUpFields is used with an untrusted placeholder.
Affected products
- auth0 lock: before 11.21.0 — fixed in 11.21.0
How to fix
Upgrade to a fixed version: auth0 lock 11.21.0. Check the vendor advisory for mitigations.
References
- https://auth0.com/docs/security/bulletins/cve-2019-20174
- https://github.com/auth0/lock/releases/tag/v11.21.0
- https://auth0.com/docs/security/bulletins/cve-2019-20174
- https://github.com/auth0/lock/releases/tag/v11.21.0
Get alerted when CVE-2019-20174 or the next vulnerability affects your stack