What’s Vulnerable › Vulnerabilities
CVE-2019-20367
- Severity: critical (CVSS 9.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.9% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2020-01-08 · updated 2026-10-14
- Weakness: CWE-125
Description
nlist.c in libbsd before 0.10.0 has an out-of-bounds read during a comparison for a symbol name from the string table (strtab).
Affected products
- Canonical Ubuntu Linux: 12.04, 14.04, 16.04, 18.04, 19.04
- Debian Linux: 9.0
- Freedesktop Libbsd: before 0.10.0 — fixed in 0.10.0
- openSUSE Leap: 15.1
How to fix
Upgrade to a fixed version: Freedesktop Libbsd 0.10.0. Check the vendor advisory for mitigations.
References
- http://lists.opensuse.org/opensuse-security-announce/2020-05/msg00043.html
- https://gitlab.freedesktop.org/libbsd/libbsd/commit/9d917aad37778a9f4a96ba358415f077f3f36f3b
- https://lists.apache.org/thread.html/r0e913668380f59bcbd14fdd8ae8d24f95f99995e290cd18a7822c6e5%40%3Cdev.tomee.apache.org%3E
- https://lists.apache.org/thread.html/ra781e51cf1ec40381c98cddc073b3576fb56c3978f4564d2fa431550%40%3Cdev.tomee.apache.org%3E
- https://lists.debian.org/debian-lts-announce/2021/02/msg00027.html
- https://lists.freedesktop.org/archives/libbsd/2019-August/000229.html
- https://usn.ubuntu.com/4243-1/
- http://lists.opensuse.org/opensuse-security-announce/2020-05/msg00043.html
- https://gitlab.freedesktop.org/libbsd/libbsd/commit/9d917aad37778a9f4a96ba358415f077f3f36f3b
- https://lists.apache.org/thread.html/r0e913668380f59bcbd14fdd8ae8d24f95f99995e290cd18a7822c6e5%40%3Cdev.tomee.apache.org%3E
- https://lists.apache.org/thread.html/ra781e51cf1ec40381c98cddc073b3576fb56c3978f4564d2fa431550%40%3Cdev.tomee.apache.org%3E
- https://lists.debian.org/debian-lts-announce/2021/02/msg00027.html
Get alerted when CVE-2019-20367 or the next vulnerability affects your stack