What’s Vulnerable › Vulnerabilities
CVE-2019-20372
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 15.0% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2020-01-09 · updated 2026-06-17
- Weakness: CWE-444
Description
NGINX before 1.17.7, with certain error_page configurations, allows HTTP request smuggling, as demonstrated by the ability of an attacker to read unauthorized web pages in environments where NGINX is being fronted by a load balancer.
Affected products
- Apple Xcode: before 13.0 — fixed in 13.0
- Canonical Ubuntu Linux: 14.04
- nginx: before 1.17.7 — fixed in 1.17.7
- NetApp Cloud Backup: all versions
- openSUSE Leap: 15.1
How to fix
Upgrade to a fixed version: Apple Xcode 13.0; nginx 1.17.7. Check the vendor advisory for mitigations.
References
- http://lists.opensuse.org/opensuse-security-announce/2020-02/msg00013.html
- http://nginx.org/en/CHANGES
- http://seclists.org/fulldisclosure/2021/Sep/36
- https://bertjwregeer.keybase.pub/2019-12-10%20-%20error_page%20request%20smuggling.pdf
- https://duo.com/docs/dng-notes#version-1.5.4-january-2020
- https://github.com/kubernetes/ingress-nginx/pull/4859
- https://github.com/nginx/nginx/commit/c1be55f97211d38b69ac0c2027e6812ab8b1b94e
- https://security.netapp.com/advisory/ntap-20200127-0003/
- https://support.apple.com/kb/HT212818
- https://usn.ubuntu.com/4235-1/
- https://usn.ubuntu.com/4235-2/
- http://lists.opensuse.org/opensuse-security-announce/2020-02/msg00013.html
Get alerted when CVE-2019-20372 or the next vulnerability affects your stack