What’s Vulnerable › Vulnerabilities
CVE-2019-20381
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-01-20 · updated 2026-06-17
- Weakness: CWE-79
Description
TestLink before 1.9.20 allows XSS via non-lowercase javascript: in the index.php reqURI parameter. NOTE: this issue exists because of an incomplete fix for CVE-2019-19491.
Affected products
- Testlink: before 1.9.20 — fixed in 1.9.20
How to fix
Upgrade to a fixed version: Testlink 1.9.20. Check the vendor advisory for mitigations.
References
- http://mantis.testlink.org/view.php?id=8808
- https://github.com/TestLinkOpenSourceTRMS/testlink-code/commit/cde692895e425731e6951d265a01ca6425a7c26e
- https://github.com/TestLinkOpenSourceTRMS/testlink-code/compare/1.9.19...1.9.20
- http://mantis.testlink.org/view.php?id=8808
- https://github.com/TestLinkOpenSourceTRMS/testlink-code/commit/cde692895e425731e6951d265a01ca6425a7c26e
- https://github.com/TestLinkOpenSourceTRMS/testlink-code/compare/1.9.19...1.9.20
Get alerted when CVE-2019-20381 or the next vulnerability affects your stack