What’s Vulnerable › Vulnerabilities
CVE-2019-20387
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-01-21 · updated 2026-06-17
- Weakness: CWE-125
Description
repodata_schema2id in repodata.c in libsolv before 0.7.6 has a heap-based buffer over-read via a last schema whose length is less than the length of the input schema.
Affected products
- Debian Linux: 8.0
- OpenSUSE libsolv: before 0.7.6 — fixed in 0.7.6
How to fix
Upgrade to a fixed version: OpenSUSE libsolv 0.7.6. Check the vendor advisory for mitigations.
References
- https://github.com/openSUSE/libsolv/commit/fdb9c9c03508990e4583046b590c30d958f272da
- https://github.com/openSUSE/libsolv/compare/0.7.5...0.7.6
- https://lists.debian.org/debian-lts-announce/2020/01/msg00034.html
- https://github.com/openSUSE/libsolv/commit/fdb9c9c03508990e4583046b590c30d958f272da
- https://github.com/openSUSE/libsolv/compare/0.7.5...0.7.6
- https://lists.debian.org/debian-lts-announce/2020/01/msg00034.html
Get alerted when CVE-2019-20387 or the next vulnerability affects your stack