What’s Vulnerable › Vulnerabilities
CVE-2019-20427
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 5.1% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2020-01-27 · updated 2026-06-17
- Weakness: CWE-120
Description
In the Lustre file system before 2.12.3, the ptlrpc module has a buffer overflow and panic, and possibly remote code execution, due to the lack of validation for specific fields of packets sent by a client. Interaction between req_capsule_get_size and tgt_brw_write leads to a tgt_shortio2pages integer signedness error.
Affected products
- Lustre: before 2.12.3 — fixed in 2.12.3
How to fix
Upgrade to a fixed version: Lustre 2.12.3. Check the vendor advisory for mitigations.
References
- http://lustre.org/
- http://wiki.lustre.org/Lustre_2.12.3_Changelog
- https://jira.whamcloud.com/browse/LU-12600
- https://review.whamcloud.com/#/c/35867/
- http://lustre.org/
- http://wiki.lustre.org/Lustre_2.12.3_Changelog
- https://jira.whamcloud.com/browse/LU-12600
- https://review.whamcloud.com/#/c/35867/
Get alerted when CVE-2019-20427 or the next vulnerability affects your stack