What’s Vulnerable › Vulnerabilities
CVE-2019-20428
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-01-27 · updated 2026-06-17
- Weakness: CWE-125
Description
In the Lustre file system before 2.12.3, the ptlrpc module has an out-of-bounds read and panic due to the lack of validation for specific fields of packets sent by a client. The ldl_request_cancel function mishandles a large lock_count parameter.
Affected products
- Lustre: before 2.12.3 — fixed in 2.12.3
How to fix
Upgrade to a fixed version: Lustre 2.12.3. Check the vendor advisory for mitigations.
References
- http://lustre.org/
- http://wiki.lustre.org/Lustre_2.12.3_Changelog
- https://jira.whamcloud.com/browse/LU-12603
- https://review.whamcloud.com/#/c/36108/
- http://lustre.org/
- http://wiki.lustre.org/Lustre_2.12.3_Changelog
- https://jira.whamcloud.com/browse/LU-12603
- https://review.whamcloud.com/#/c/36108/
Get alerted when CVE-2019-20428 or the next vulnerability affects your stack