What’s Vulnerable › Vulnerabilities
CVE-2019-20429
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2020-01-27 · updated 2026-06-17
- Weakness: CWE-125
Description
In the Lustre file system before 2.12.3, the ptlrpc module has an out-of-bounds read and panic (via a modified lm_bufcount field) due to the lack of validation for specific fields of packets sent by a client. This is caused by interaction between sptlrpc_svc_unwrap_request and lustre_msg_hdr_size_v2.
Affected products
- Lustre: before 2.12.3 — fixed in 2.12.3
How to fix
Upgrade to a fixed version: Lustre 2.12.3. Check the vendor advisory for mitigations.
References
- http://lustre.org/
- http://wiki.lustre.org/Lustre_2.12.3_Changelog
- https://jira.whamcloud.com/browse/LU-12590
- https://review.whamcloud.com/#/c/36119/
- http://lustre.org/
- http://wiki.lustre.org/Lustre_2.12.3_Changelog
- https://jira.whamcloud.com/browse/LU-12590
- https://review.whamcloud.com/#/c/36119/
Get alerted when CVE-2019-20429 or the next vulnerability affects your stack