What’s Vulnerable › Vulnerabilities
CVE-2019-20433
- Severity: critical (CVSS 9.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-01-27 · updated 2026-06-17
- Weakness: CWE-125
Description
libaspell.a in GNU Aspell before 0.60.8 has a buffer over-read for a string ending with a single '\0' byte, if the encoding is set to ucs-2 or ucs-4 outside of the application, as demonstrated by the ASPELL_CONF environment variable.
Affected products
- GNU Aspell: before 0.60.8 — fixed in 0.60.8
How to fix
Upgrade to a fixed version: GNU Aspell 0.60.8. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2019-20433 or the next vulnerability affects your stack