What’s Vulnerable › Vulnerabilities
CVE-2019-20444
- Severity: critical (CVSS 9.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 8.9% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2020-01-29 · updated 2026-10-08
- Weakness: CWE-444
Description
HttpObjectDecoder.java in Netty before 4.1.44 allows an HTTP header that lacks a colon, which might be interpreted as a separate header with an incorrect syntax, or might be interpreted as an "invalid fold."
Affected products
- Canonical Ubuntu Linux: 18.04
- Debian Linux: 8.0, 9.0, 10.0
- Fedoraproject Fedora: 33
- netty: before 4.1.44 — fixed in 4.1.44
- RedHat Jboss Amq Clients: 2
- Red Hat JBoss EAP: 7.2, 7.3
How to fix
Upgrade to a fixed version: netty 4.1.44. Check the vendor advisory for mitigations.
References
- https://access.redhat.com/errata/RHSA-2020:0497
- https://access.redhat.com/errata/RHSA-2020:0567
- https://access.redhat.com/errata/RHSA-2020:0601
- https://access.redhat.com/errata/RHSA-2020:0605
- https://access.redhat.com/errata/RHSA-2020:0606
- https://access.redhat.com/errata/RHSA-2020:0804
- https://access.redhat.com/errata/RHSA-2020:0805
- https://access.redhat.com/errata/RHSA-2020:0806
- https://access.redhat.com/errata/RHSA-2020:0811
- https://github.com/netty/netty/compare/netty-4.1.43.Final...netty-4.1.44.Final
- https://github.com/netty/netty/issues/9866
- https://github.com/poc-effectiveness/PoCAdaptation/tree/main/Adapted/CVE-2019-20444/5.0.0.Alpha1/exploit
Get alerted when CVE-2019-20444 or the next vulnerability affects your stack