What’s Vulnerable › Vulnerabilities

CVE-2019-20446

Description

In xml.rs in GNOME librsvg before 2.46.2, a crafted SVG file with nested patterns can cause denial of service when passed to the library for processing. The attacker constructs pattern elements so that the number of final rendered objects grows exponentially.

Affected products

How to fix

Upgrade to a fixed version: GNOME Librsvg 2.40.21, 2.42.8, 2.44.16. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2019-20446 or the next vulnerability affects your stack