What’s Vulnerable › Vulnerabilities
CVE-2019-20455
- Severity: medium (CVSS 5.9 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2020-02-14 · updated 2026-06-17
- Weakness: CWE-295
Description
Gateways/Gateway.php in Heartland & Global Payments PHP SDK before 2.0.0 does not enforce SSL certificate validations.
Affected products
- Globalpayments Php Sdk: before 2.0.0 — fixed in 2.0.0
How to fix
Upgrade to a fixed version: Globalpayments Php Sdk 2.0.0. Check the vendor advisory for mitigations.
References
- https://github.com/globalpayments/php-sdk/compare/1.3.3...2.0.0
- https://github.com/globalpayments/php-sdk/pull/8
- https://github.com/globalpayments/php-sdk/releases/tag/2.0.0
- https://winterdragon.ca/global-payments-vulnerability/
- https://github.com/globalpayments/php-sdk/compare/1.3.3...2.0.0
- https://github.com/globalpayments/php-sdk/pull/8
- https://github.com/globalpayments/php-sdk/releases/tag/2.0.0
- https://winterdragon.ca/global-payments-vulnerability/
Get alerted when CVE-2019-20455 or the next vulnerability affects your stack