What’s Vulnerable › Vulnerabilities
CVE-2019-20485
- Severity: medium (CVSS 5.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-03-19 · updated 2026-06-17
- Weakness: CWE-20
Description
qemu/qemu_driver.c in libvirt before 6.0.0 mishandles the holding of a monitor job during a query to a guest agent, which allows attackers to cause a denial of service (API blockage).
Affected products
- Debian Linux: 8.0, 9.0, 10.0
- Fedoraproject Fedora: 31
- libvirt: before 6.0.0 — fixed in 6.0.0
How to fix
Upgrade to a fixed version: libvirt 6.0.0. Check the vendor advisory for mitigations.
References
- https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=953078
- https://bugzilla.redhat.com/show_bug.cgi?id=1809740
- https://libvirt.org/git/?p=libvirt.git%3Ba=commit%3Bh=a663a860819287e041c3de672aad1d8543098ecc
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/D5GE6ISYUL3CIWO3FQRUGMKTKP2NYED2/
- https://security-tracker.debian.org/tracker/CVE-2019-20485
- https://www.mail-archive.com/debian-bugs-dist%40lists.debian.org/msg1730509.html
- https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=953078
- https://bugzilla.redhat.com/show_bug.cgi?id=1809740
- https://libvirt.org/git/?p=libvirt.git%3Ba=commit%3Bh=a663a860819287e041c3de672aad1d8543098ecc
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/D5GE6ISYUL3CIWO3FQRUGMKTKP2NYED2/
- https://security-tracker.debian.org/tracker/CVE-2019-20485
- https://www.mail-archive.com/debian-bugs-dist%40lists.debian.org/msg1730509.html
Get alerted when CVE-2019-20485 or the next vulnerability affects your stack