What’s Vulnerable › Vulnerabilities
CVE-2019-20504
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 9.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2020-03-09 · updated 2026-06-17
- Weakness: CWE-78
Description
service/krashrpt.php in Quest KACE K1000 Systems Management Appliance before 6.4 SP3 (6.4.120822) allows a remote attacker to execute code via shell metacharacters in the kuid parameter.
Affected products
- Quest Kace Systems Management: before 6.4.120822 — fixed in 6.4.120822
How to fix
Upgrade to a fixed version: Quest Kace Systems Management 6.4.120822. Check the vendor advisory for mitigations.
References
- https://www.rcesecurity.com/2019/04/dell-kace-k1000-remote-code-execution-the-story-of-bug-k1-18652/
- https://www.rcesecurity.com/2019/04/dell-kace-k1000-remote-code-execution-the-story-of-bug-k1-18652/
Get alerted when CVE-2019-20504 or the next vulnerability affects your stack