What’s Vulnerable › Vulnerabilities
CVE-2019-20627
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2020-03-23 · updated 2026-06-17
- Weakness: CWE-611
Description
AutoUpdater.cs in AutoUpdater.NET before 1.5.8 allows XXE.
Affected products
- Rbsoft Autoupdater.Net: before 1.5.8 — fixed in 1.5.8
How to fix
Upgrade to a fixed version: Rbsoft Autoupdater.Net 1.5.8. Check the vendor advisory for mitigations.
References
- https://github.com/ravibpatel/AutoUpdater.NET/commit/1dc25f2bea6ea522dbac1512b5563c4746d539c3
- https://github.com/ravibpatel/AutoUpdater.NET/releases/tag/v1.5.8
- https://www.doyler.net/security-not-included/autoupdater-net-vulnerability
- https://github.com/ravibpatel/AutoUpdater.NET/commit/1dc25f2bea6ea522dbac1512b5563c4746d539c3
- https://github.com/ravibpatel/AutoUpdater.NET/releases/tag/v1.5.8
- https://www.doyler.net/security-not-included/autoupdater-net-vulnerability
Get alerted when CVE-2019-20627 or the next vulnerability affects your stack